Resolved
This incident has been resolved. Thank you for your patience.
Monitoring
Issue was resolved. We'll continue monitoring
Investigating
We're currently experiencing degraded performance affecting how quickly updates are processed across the platform. As a result, some recently entered or synced data may take longer than usual to appear, and reports may show stale figures until processing catches up.