Resolved
This incident has been resolved. All delayed updates and affected events have been processed, and reports now reflect the correct, up-to-date data. Thank you for your patience.
Monitoring
A fix has been deployed and the platform is processing updates normally again. We are now working through the backlog of delayed updates. Some reports may continue to show stale data until this catches up. We're monitoring closely and will confirm once fully resolved.
Identified
We're currently experiencing degraded performance affecting how quickly updates are processed across the platform. As a result, some recently entered or synced data may take longer than usual to appear, and reports may show stale figures until processing catches up.
We have identified the cause and a fix is being deployed. No data has been lost.